Digital Video Forums

Go Back   Digital Video Forums > Video File Formats > MP4, MKV, MPEG-4 AVC (H.264)

Reply
 
LinkBack Thread Tools Rate Thread Display Modes
Old 7 May 2015, 04:01 AM   #1
Junior Member
Junior Member
 
Join Date: May 2015
Posts: 1
Unhappy-2 Force change MP4 properties

Hi, I've read there something similar, but nothing helps me yet. :/

Ok, I am not new to creating subtitles and making hardsub in MP4. I am used to Avidemux, latest version.

This time, I have got the raw video file in FullHD through some Portuguese site. It was just a luck ľ there is no other version of the video in this quality.

According to Media Player Classic, the input properties are:

(MKV file)

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High 10@L5.1
Format settings, CABAC : Yes
Format settings, ReFrames : 16 frames
Codec ID : V_MPEG4/ISO/AVC
Duration : 22mn 45s
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 30.000 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 10 bits
Scan type : Progressive
Title : Animes Recode Encode
Writing library : x264 core 136 r2348+704+51 d1baef6 tMod [10-bit@all X86_64]
Encoding settings : cabac=1 / ref=16 / deblock=1:1:1 / analyse=0x3:0x133 / me=umh / subme=10 / psy=1 / fade_compensate=0.00 / psy_rd=0.40:0.00 / mixed_ref=1 / me_range=24 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=6 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / fgo=0 / bframes=8 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=1 / scenecut=45 / intra_refresh=0 / rc_lookahead=40 / rc=crf / mbtree=1 / crf=24.0000 / qcomp=0.60 / qpmin=10:10:10 / qpmax=51:51:51 / qpstep=4 / ip_ratio=1.40 / aq=3:0.50 / aq-sensitivity=10.00 / aq-factor=1.00:1.00:1.00 / aq2=0 / aq3=0
Language : English
Default : Yes
Forced : No
DURATION : 00:22:44.567000000
NUMBER_OF_FRAMES : 40938
NUMBER_OF_BYTES : 164497833
_STATISTICS_WRITING_APP : mkvmerge v7.8.0 ('River Man') 64bit built on Mar 27 2015 16:31:37
_STATISTICS_WRITING_DATE_UTC : 2015-04-14 14:55:14
_STATISTICS_TAGS : BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES


I have created subtitles in Aegisub and in the softsub it works perfect.

I have created a hardsub the usual way and it looks perfect, too, but the properties are messed up whatever I try:

(MP4 file)

Video
ID : 0
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.0
Format settings, CABAC : Yes
Format settings, ReFrames : 4 frames
Codec ID : H264
Duration : 27mn 17s
Bit rate : 2 030 Kbps
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate : 25.000 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.039
Stream size : 396 MiB (91%)
Writing library : x264 core 123 r2189 35cf912
Encoding settings : cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x3:0x133 / me=hex / subme=7 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=3 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=crf / mbtree=1 / crf=20.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00


As you can see, frame rate changed from 30.000 fps to 25.000 fps, but NUMBER_OF_FRAMES must have stayed the same, because duration increased exactly by 20%.

Due to that, the video goes more slowly than the sound and some programes (like MP Classic or XMedia Recode) even show the duration as 219:58:39.

I don't need to reencode the file, I need to manually change the frame rate and set the end of the file.

(As I imply in the middle, I have already tried to manually set frame rate before encoding in Avidemux ľ nothing happened even for impossible values. Every try takes about 5 hours, I am doing another one right now.)

Can you please help me?
Ovac is offline   Reply With Quote
Reply

Bookmarks

Tags
mp4 properties


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Display Properties dazuk1972 General Computing 2 13 Jun 2010 03:58 AM
Force change in subtitle position!? lostinlodos2 DVD Authoring and Editing 2 17 Jun 2007 08:06 PM
codec properties o770 Junior Members/Newbies 8 16 Mar 2003 12:27 PM
Change DivX Movie Properties kookykrazee DivX/XviD Conversion/Encoding 5 26 Apr 2002 11:22 AM
How to change the frame rate without change the Audio/Video synchronization. lutchoj Authoring 1 24 Jan 2002 12:59 PM



All times are GMT +10. The time now is 07:59 AM.

Kirsch designed by Andrew & Austin


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
Copyright © 1999 - 2011 Digital Digest

Visit DivXLand   Visit dvdloc8.com