Digital Video Forums

Go Back   Digital Video Forums > Other > Archive (Closed) > TMPGEnc

 
 
LinkBack Thread Tools Rate Thread Display Modes
Old 25 Feb 2007, 09:12 PM   #1
Junior Member
Junior Member
 
Join Date: Mar 2005
Posts: 11
Default TMPGenc & Sync. + grain (used to be fine)

Hi All,
I recently upgraded to Vista Ultimate from XP Pro (Some might say, downgraded). I realise this was my first mistake.

I convert a lot of 24fps (hereafter known as NTSC) to 25fps (hereafter known as PAL).

The process I used to use for excellent sound and visual quality was:
1) Load VirtualDub, and save the audio as a wav. Convert the avi to PAL without audio. Usually shortens a 43minute NTSC to about 41minute Pal.

2) Load BeSweet. Convert the NTSC .Wav file to a PAL .MP2

3) Use TMPGenc 2.5x to convert the PAL avi to mpg, using the MP2 for audio.

Once this was all batched up, it was a smooth process.
, and I could burn them all to dvd.

Now with Vista it has been a living hell getting everything backtogether.

I thought I had finally made it, but...

I cannot get the audio in sync when using TMPGenc.

If I take a PAL avi without sound, and use an MP2, I find the sound is a fraction of a second before the video.

So I take the NTSC WAV, and use Goldwave to make it the same length as the avi, then TMPGenc it: Same result.

So I tried using VDub to to convert to PAL WITH audio (checking the option to make audio and video the same length). This gives me a PAL avi, the same length as the NTSC original, but there is the jerk every now and again as the extra frames are inserted. I could possibly tolerate that, but when I use TMPGenc to convert to mpg... Yup, the audio is a fraction of a second too early.

I have tried every combination using every combination of vfapi priority (including the direct show which defaults to -1)

On top of that, the quality seems to be a lot blockier then it used to under XP. Also playback in MediaPlayer 11 seems to be blockier in general for other files.

I have downloaded the Vista Codec pack, and uninstalled it as I wasn't happy with some of it.

Currently have divx6, ac3 filter (and ac3 codec in system32), xvid, ffdshow, vobsub.

Hmmm. Just been checking as I write this. In vdub, If I convert to 25fps and put audio on Full Processing Mode, then the audio is a fraction of a second too early. But if I leave the audio on direct stream copy, then it is in sync and actually stays in sync in TMPGenc (But I have the jerk of the extra frames)

So perhaps this is actually an audio codec problem and not a TMPgenc problem?

Gspot(vista fix version) says codec is: 0x2000 (Dolby AC3)

Very annoyed BeSweet is doing this to me as it used to work fine.

Any suggestions anyone?
AVI-Editor is offline  
Old 26 Feb 2007, 12:59 AM   #2
Junior Member
Junior Member
 
Join Date: Mar 2005
Posts: 11
Default

After a bit more playing, I found that if I delay by 300ms in BeSweet, then the TMPGEnc output starts of in sync, but by the end of the 41 minute mpg, the audio is almost a second ahead of the video (maybe more).

Also the video quality is very blocky, almost looks like a mosaic or made of lego
AVI-Editor is offline  
Old 26 Feb 2007, 02:39 AM   #3
Banned
 
ed klein's Avatar
 
Join Date: Mar 2004
Location: Over The Edge
Posts: 880
Default

Wow, great effort to keep things in sync.

Here are just some thoughts and another similar method to which I think is the same results you are looking for.

1. Try to keep ALL FILES in the same folder, for me this helped to keep video and audio in sync.

2. Two forms of NTSC at 29.97fps and 23.97fps (inverse 3:2 pulldown) to convert to PAL at 25. fps

3. Throw Vista in the trash and put XP back on your machine

4. Try this method to keep video and audio in sync:
Use DGIndex VOBS as input and D2V video file and WAVE audio file as output

Use TMPGEnc Plus as the encoder D2V video file as input and WAVE audio file as input, output M2V video file down to 4.37gb and MP2 audio file.

Use VobEdit to get the audio AC-3 file and subtitles file, DVD Decrypter to get the chapters file.

Use IFOEDIT to author the M2V video file, AC-3 audio file, subtitles file, chapters file. IFOEDIT has an option to adjust the audio and video if they are out of sync in ms.

Use Imgburn to convert the VIDEO TS FOLDER to and ISO image and burn to a DVD-5.

ed klein is offline  
Old 26 Feb 2007, 03:40 AM   #4
Junior Member
Junior Member
 
Join Date: Mar 2005
Posts: 11
Default

Thanks for the response.

I meant to add that going back to xp wasn't an option

RE NTSC, I'm only dealing with 23.976

All files in same folder, possibly, just annoying as it used work fine. And in my testing at the moment, the files are in the same directory.

Does appear that TMPGenc is gradually throwing the audio out of sync for whatever reason. I am sure I had this same problem years ago, and fixed it.

What I tried just now was:
Converted the palavi to palmpeg, noted down the length.
Took the wav, used goldwave to shrink it to same length.
Ran TMPgenc again using the newlength wav, out of sync. And again with an MP2 version. Out of synch. Just what the hell is TMPGenc doing to my audio? And why is it looking so pixelated?

EIDT-->>
I should have mentioned: I am converting the avi to vcd-PAL-mpg, then will take a bunch of mpg and used TMGDVDAuthor to make a DVD of them.

Last edited by AVI-Editor; 26 Feb 2007 at 04:39 AM
AVI-Editor is offline  
Old 26 Feb 2007, 08:58 PM   #5
Junior Member
Junior Member
 
Join Date: Mar 2005
Posts: 11
Default Ac3?

Upon further fiddling, I think there is something wrong with my AC3 config.

If I put the original 24fps .avi into TMPGenc and convert to mpg24fps, everything is fine. I can convert to 30fps too using 3:2pulldown. Everything is in sync.

But as soon as I use my BeSweet mp2 (converted from 24pfs to 25 fps), the audio goes out of sync. (Starts off insync, then gradually gets worse and worse)

Also, if I use vdub to force the 24 into a 25fps (and force it to keep the audio and video the same length, inserts frames so you get that jitter), the avi is in sync, but as it goes through tmpgenc, it goes out of sync. But id I do all that with audio in full processing mode, the avi audio is out of sync.

This makes me think it is an ac3 problem rather then tmpgenc?
AVI-Editor is offline  
Old 27 Feb 2007, 06:57 PM   #6
Junior Member
Junior Member
 
Join Date: Mar 2005
Posts: 11
Default

Further discovery:

I tried running a PAL xvid-avi through TMPGenc (converting to PAL mpg vcd, without doing anything to the audio), and it converted just fine (in sync).

This leads me to believe that either:

1) vdub is incorrectly ripping the wav file.
or
2) BeSweet is incorrectly converting the wav to mp2

If I take the wav from vdub, and use goldwave to shrink it to the same length as the final file, it still goes out of synch (i.e. it has never even seen besweet). So is there something wrong with ac3 in vdub? Should this thread be moved?
AVI-Editor is offline  
Old 27 Feb 2007, 07:22 PM   #7
Junior Member
Junior Member
 
Join Date: Mar 2005
Posts: 11
Default

a double post, 25 minutes after the original?

Nice.

What is up with your servers guys?
AVI-Editor is offline  
 

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
WMP sync fine...Vdub sync terrible chickeneater General Discussions 6 16 Feb 2003 06:30 AM
SVCD fine on PC- audio out of sync on DVD player Far_out_si Junior Members/Newbies 5 2 Nov 2002 03:22 AM



All times are GMT +10. The time now is 07:15 AM.

Kirsch designed by Andrew & Austin


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
Copyright © 1999 - 2011 Digital Digest

Visit DivXLand   Visit dvdloc8.com