Digital Video Forums

Go Back   Digital Video Forums > Other > Archive (Closed) > General Discussions

 
 
LinkBack Thread Tools Rate Thread Display Modes
Old 29 Jun 2004, 06:39 AM   #1
Junior Member
Junior Member
 
Join Date: Jun 2004
Posts: 6
Unhappy Can't watch some movies...

Hi everyone
I can watch on my computer movies that are 25fps, but when I watch movies with 23fps it shows in slow motion. can anyone tell me what is wrong with my PC, and if there's any way I can fix it?

thank you LoLo
LoLo_c is offline  
Old 29 Jun 2004, 07:24 AM   #2
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

1) Load the original problematic video file into VirtualDub (or one of its many variants) or NanDub

2) From the "File" dropdown menu, select "File Information"

3) Post (here) EVERYTHING you see (BOTH video and audio information), or post a screen capture .jpg of the information box
setarip is offline  
Old 29 Jun 2004, 09:51 AM   #3
Junior Member
Junior Member
 
Join Date: Jun 2004
Posts: 6
Default

Hi
I couldn't open the video with VirtualDub, it gave me an error massage, but here are the video detailes from another software, I hope it's OK.

thank you
Attached Thumbnails
Can't watch some movies...-movie.jpg  
LoLo_c is offline  
Old 29 Jun 2004, 08:46 PM   #4
Digital Video Master
Digital Video Master
 
Join Date: Jul 2003
Posts: 1,000
Default

the codec used in this movie is the Microsoft Mpeg 4 v3
codec the audiocodec is ac3.
what you need is a codec that supports that.
the MS mpeg4 codec can be downloaded at MS Homepage itself,
or here:
http://www.divx-digest.com/software/mpeg4codec.html

(on Microsoft page this codec comes with an executable installer)

a proper ac3 filter can be found on the softwaresection of this site or better here:
http://sourceforge.net/projects/ac3filter
if needed.
I also recommend a proper player to view your mpeg4 movies.
my favorite one is the BS Player seconded by the MV2 player.
both can be grabbed for free from the softwaresection of this site.

http://www.divx-digest.com/software/index4.html#players
choose one that suits you best.
shiny#3 is offline  
Old 30 Jun 2004, 03:07 AM   #5
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

This particular file may have had the .AC3 audiostream added with an inappropriate interleave and preload...
setarip is offline  
Old 30 Jun 2004, 10:46 AM   #6
Junior Member
Junior Member
 
Join Date: Jun 2004
Posts: 6
Smile

Thank you again for all your help. I can see the movies a bit faster, but still not in their right speed..
could this have anything to do with my video card? (pretty old one- Trident accelerator blade 3D/ProMedia)

LoLo
LoLo_c is offline  
Old 30 Jun 2004, 09:16 PM   #7
Digital Video Master
Digital Video Master
 
Join Date: Jul 2003
Posts: 1,000
Default

your Trident accelerator blade 3D/ProMedia should be
fast enough to display movies its just 24 fps and 50 in split.
(at least to my knowledge)
the problem is software based, I assume and setarip did also,
I guess.

following could be the reason.

1.you have a "multiple call" of codecs jumping in , trying to decode
your movie.

2. a codec pack has brought along some Reclocking Software Device that tries to get your video back into sync. maybe the
device is outdated and therefore does not know how to handle
this particular moviefile correctly.

3. setarips assumption accounts for the retarded playback.

first let us try to rule out reason 3.
load that video with WinDVD or powerDVD if you have, and check performance. they bring along their on ac3 decoders not visible
to the system. check performance ! if the problem persists,
do the following: load movie into virtualdub mod or nandub.
disable audio and save as "silent" avi under a new filename.
play it! if it runs smoothly now, then either setarip is right, or reason No.2 ist the case. If it plays smoothly in Windvd /Power DVD No 2 is the case.

workaround:
if setarip is right then you have no choice but reinterleaving
the movie with the help of virtualdub mod. the right values can be found in this forum for preload and interleave.
but I guess it is 192kbps (2 ch) Preload: 80ms , Interleave: 80ms.

no.1 and or no.2 is the case you have a codec conflict.
so remove ALL codec packs from your system. also delete
all Divx /xvid/ mpeg4 codecs that you have downloaded and installed. also all ac3 codecs and reclocking devices that you have.
if you have problems doing this use the "codec sniper"
to do so. note: do not delete codecs brought along by windvd or powerdvd or a special movie editing software such as Davideo3 pro or mainconcept or else. (they normally reside in their installation folders)

do also remove AC3 codecs if you have more than one installed

reinstall the following codecs.
1. Divx Pro latest version. set this one to support generic mpeg4
in the configuration utility (quality settings) if neccesary enable smooth playback.there is an adware financed version in the softwaresectionof this site. install and reboot anew.

to disable the spyware in this codec:

start--> execute-> type in >msconfig< . (without the brackets)
then refer to the autostart menue of the new window, that pops up. here you will find a program named "Trickler" or "GainTrickler"
just disable this one and it won┤t spy again.

2.Xvid Codec latest stable Version. do not enable the support for
other codecs during installation of the xvid codec.
3. the microsoft mpeg4 codecs. along with Indeo codecs
(MS HOMEPAGE)

you should be able to decode almost any avifile by now.
if not, install missed codecs afterwards "by hand". do not use codec packs.
do not use the FFD show codec until you know exactly what you
are doing!!!!! it caused many problems (according to the experience of users in a lot of forums. especially with computers
of lesser performance.)

hope this helps

Last edited by shiny#3; 30 Jun 2004 at 09:19 PM
shiny#3 is offline  
Old 1 Jul 2004, 05:55 AM   #8
Junior Member
Junior Member
 
Join Date: Jun 2004
Posts: 6
Smile

Hi shiny#3! thank you so much for helping me! I removed all my codecs and installed Divx Pro and Indeo codecs, but I couldn't find Xvid Codec and microsoft mpeg 4 codecs. where can I find them? and should I install AC3 filter again?
I hope that the codecs were the problem.

LoLo
LoLo_c is offline  
Old 1 Jul 2004, 08:09 AM   #9
Junior Member
Junior Member
 
Join Date: Jun 2004
Posts: 6
Default

I played the video in virtual dub, mute, and it was still slow.. I tried playing it in Divx, Xvid, BSplayer and even Avi Preview. it was all the same.
Before I installed AC3filter I played the video with Divx and it was OK. so the problem must have something to do with that.
I'm sorry for bugging you, it's just that my job involves creating videos and it's imposible right now. so thank you once again, your'e great help

LoLo!
LoLo_c is offline  
Old 2 Jul 2004, 07:53 PM   #10
Digital Video Master
Digital Video Master
 
Join Date: Jul 2003
Posts: 1,000
Default

the wm9 codecs which include the the MS Mpeg4 codecs
can be found here filename is WM9Codecs.exe

http://www.uni-weimar.de/~richte10/dvd_eng.html

in addition to that: of course you must have an AC3 codec installed to hear sound encoded in AC3.

but .... chances are that the "videofixer" wich is available
on www.divx-digest.com can repair the bad index of the video/audio.

your ac3 audiostream is only in stereo anyway.
so why not demux it with virtualdub mod or nandub
and the use headac3 he to make a mp3 audiostream out of it and then reinterleave it with virtual dub??

Last edited by shiny#3; 2 Jul 2004 at 07:55 PM
shiny#3 is offline  
Old 3 Jul 2004, 03:02 AM   #11
Junior Member
Junior Member
 
Join Date: Jun 2004
Posts: 6
Default

"your ac3 audiostream is only in stereo anyway.
so why not demux it with virtualdub mod or nandub
and the use headac3 he to make a mp3 audiostream out of it and then reinterleave it with virtual dub??"

I have no idea how to do it... \:
I never used virtualdub before.
LoLo_c is offline  
Old 4 Jul 2004, 03:27 AM   #12
Digital Video Master
Digital Video Master
 
Join Date: Jul 2003
Posts: 1,000
Default

this is very easy to perform:

load your video into VirtualDubMOD (not virtual dub!!!!)
to do this go to the menu called "file" use the option "load video"
and browse to the location of the video.
then refer to the drop-down menu which is called "streams" go to
streamlist. Hit Demux and enter a filename.
VirtualDubMOD now creates an AC 3 out of your video.

you can now use headac3 he to convert your AC3 stream into MP3.

then simply start VirtualDubMOD again. load your video again.
go to streamlist again click on the AC 3 Stream until its greys out
hit that button "add" and browse to the mp3 Stream.
go to the menu called "video" and choose "direct stream copy"

go to the menu called "file" and safe as new avi under a different
filename.
you should be done.

there is also a method to do this without the help of headAC3 He
but since your AC 3 stream has made problems I suggest the
explained method.
shiny#3 is offline  
Old 4 Jul 2004, 07:21 AM   #13
Junior Member
Junior Member
 
Join Date: Aug 2002
Posts: 4
Smile

Thank you very very much for all your help!

LoLo!
LoLo is offline  
 

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT +10. The time now is 07:17 AM.

Kirsch designed by Andrew & Austin


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
Copyright © 1999 - 2011 Digital Digest

Visit DivXLand   Visit dvdloc8.com