Digital Video Forums

Go Back   Digital Video Forums > Disc Formats > DVD Blank Media, Burning, Recording Hardware

Reply
 
LinkBack Thread Tools Rate Thread Display Modes
Old 23 Nov 2004, 01:59 PM   #1
Member
Member
 
Join Date: Aug 2004
Location: Huntsville, AL
Posts: 55
Lightbulb CRC errors corrupt drive, burning problem fixed!

Here it is lamans terms:

Bad media causes CRC (Cyclic Redundancy Codes) errors when read by any DVD-ROM player (stand along or PC). For your stand along player, you get pauses/freezes/pixalation. Your PC does something different.

When a CRC error comes across your IDE port (DVD drive), Windows will count how many errors it gets. An ideal transfer of data between your DVD-drive and your motherboard is had via a Dynamic Memory Access, which makes for less tasking on the CPU (performance percentage). However, as errors accumulate, windows will actively regulate DMA. If things get really bad, it reduces to PIO (programable input/ouput), which is very slow and causes the CPU to handle the brunt of the tasks. this means more CPU cycles, and more percentage. For burning, you will see "bursts" of CPU percentage being used.

This forced reversion to PIO will stay for ever and ever regardless of new better media being inserted. Thus causing failed burning on that drive untill the check-sum of errors is erased from the windows registry.


So, my stint of bad media, which had CRC errors at the end of the Memorex 8x disc, was hurting my DMA more and more each time I did a disc test. Trying to find my media problem made my problem a longterm one!!!

Here is a more in depth writeup about the problem:

Quote:
DMA Reverts to PIO
General Description
This article also applies to Windows 2000. (Peter Frank reported successful
application on Windows 2000 with Service Pack 4.)
DMA is an abbreviation for Direct Memory Access, an access method for
external devices where the data transfer is not done by the central
processor, but by a small special processor called DMA controller. It uses a
procedure called cycle stealing, where the central processor memory access
cycles are delayed for very short times to intersperse DMA controller memory
access cycles. Some newer, faster DMA modes are called UDMA (Ultra DMA).
The alternative, slow and inefficient data transfer mode is called PIO,
Programmed Input-Output, where the central processor transfers data byte for
byte or word for word. This requires many processor commands for each data
word and therefore causes a high and unwanted processor load.
Windows contains a trap in which quite a few computers seem to get caught
sooner or later. The trap is described in the following article (and also in
another one mentioned below):
DMA Mode for ATA/ATAPI Devices in Windows XP
http://www.microsoft.com/whdc/hwdev/...e/IDE-DMA.mspx
The crucial paragraphs are:
PIO mode is enabled by default in the following situations:
...
For repeated DMA errors. Windows XP will turn off DMA mode for a device
after encountering certain errors during data transfer operations. If more
that six DMA transfer timeouts occur, Windows will turn off DMA and use only
PIO mode on that device.
In this case, the user cannot turn on DMA for this device. The only option
for the user who wants to enable DMA mode is to uninstall and reinstall the
device.
Windows XP downgrades the Ultra DMA transfer mode after receiving more than
six CRC errors. Whenever possible, the operating system will step down one
UDMA mode at a time (from UDMA mode 4 to UDMA mode 3, and so on).
...
Of course, drive firmware being quite complex and certainly containing
programming defects of its own, it is not all that difficult to produce such
errors. In my case a scratched DVD and later also an unreadable (overburned)
CD did the trick, got the drive to choke and Windows to disable DMA for
good. Later my hard disk hiccupped just once and also went back to PIO for
good.
I had been using my laptop for DVD viewing for years, until I inserted a
borrowed and heavily scratched DVD. The player and apparently even the DVD
drive choked on it, and when I finally got the DVD to play, I found that
playing was jerky and processor load was 100%, roughly half of which was
system overhead.
This indicated that the drive had reverted from the usual UDMA (Ultra Direct
Memory Access) mode 2 to PIO (Programmed Input Output) mode. No amount of
resetting or changing the relevant registry parameters from 1 (try DMA) to 2
(force DMA) helped. Stubbornly the drive kept using PIO mode, and Windows
even changed these settings back to 0 (use PIO only).
The following text will refer to the secondary IDE port because that is more
often affected, but essentially the same also holds for the primary IDE
port, to which the main hard disk is connected in most computers.
Check Your IDE Port Mode
First check what mode your secondary IDE port is currently working in. Go to
Device Manager: right-click on My Computer, select Properties, click on the
Hardware tag, click on the Device Manager button, click on the plus sign to
the left of IDE ATA/ATAPI Controller, double-click on the secondary IDE
channel, click on Extended Settings and check whether it is set to DMA when
available. Directly underneath that setting is a grey field that shows the
actual working mode of your IDE channel. You want the highest possible DMA
or Ultra DMA mode there, and you definitely don't want PIO mode.
Normally you don't have to use the registry editor for this, because the
normal settings are also available through the properties dialog for the IDE
port, but if you want to look at it anyway, the parameter for the secondary
IDE port can be found through regedit.exe at
HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\Scsi\Scsi Port 1
It is named Scsi only for historic reasons. Scsi Port 0 is the primary IDE
port, to which presumably your hard disk is connected.
After trying various remedies-in vain-I found the abovementioned article and
went to work again. I uninstalled the DVD drive in Device Manager and
rebooted, but that did not help either.
So I searched for more and better information, then I went on and did the
following.
Re-enable DMA using the Registry Editor
My thanks go to my fellow MVP Alexander Grigoriev who taught me this method.
Run REGEDIT. Go to the following key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\{4D36E96A-E325-11C
E-BFC1-08002BE10318}
It has subkeys like 0000, 0001, 0002, etc. Normally 0001 is the primary IDE
channel, 0002 the secondary, but other numbers can occur under certain
circumstances. Check the DriverDesc value to see which one it is.
Delete MasterIdDataChecksum or SlaveIdDataChecksum, depending on whether the
device in question is attached as master or slave, but it can't actually
hurt to delete both. Reboot. The drive DMA capabilities will be redetected.
Open Device Manager again and check whether the device is now actually using
DMA mode. If so, congratulations, you've made it (at least until the next
time Windows disables DMA).
Alternative Method-Uninstalling the Port
1. Uninstall the secondary IDE port
To do that, open Device Manager as follows. Right-click on My Computer,
select Properties, click on the Hardware tag, click on the Device Manager
button, click on the plus sign to the left of IDE ATA/ATAPI Controller,
right-click on Secondary IDE Channel, click on Uninstall. Deactivating is
not enough.
Reboot to make the changes active and permanent.
After booting Windows will automatically reinstall the IDE channel and the
DVD (or CD) drive. This Plug-n-Play process can take a little while, so give
it a minute after the boot process finishes.
2. Reactivate DMA
But this is not enough, because unfortunately Windows does not automatically
activate DMA on a DVD or CD drive. You have to tell Windows to try to use
DMA first.
For that, go to Device Manager again. Right-click on My Computer, select
Properties, click on the Hardware tag, click on the Device Manager button,
click on the plus sign to the left of IDE ATA/ATAPI Controller, double-click
on the secondary IDE channel, click on Extended Settings and change the
relevant setting from PIO only to DMA when available.
On Windows NT and 2000 you now have to reboot a second time, but Windows XP
applies the change instantly. Then you can go to the same place in Device
Manager again and check whether the device is now actually using DMA mode.
If so, all is well.
Desensitize Your Computer's IDE Channels
There's a bit more to it. The following article offers a way to reduce the
incidence of this problem, although it still doesn't solve it altogether.
IDE ATA and ATAPI Disks Use PIO Mode After Multiple Time-Out or CRC Errors
Occur
http://support.microsoft.com/?kbid=817472
Do read this article because it contains a useful long-term workaround. But
you have to go through the procedure described here to re-enable DMA first.
Assuming you've done that, insert the ResetErrorCountersOnSuccess registry
values mentioned in this article into both the primary and the secondary IDE
port registry keys as described.
Unfortunately this is only a half solution, because when you enter an
unreadable DVD, you will get 6 errors in a row, and the IDE channel will
revert to PIO mode, but at least when you pull out the DVD in time and then
insert a good one, the error counter will be reset and it will at least be a
bit more difficult for Windows to hobble your IDE drive.
Special thanks to Joe at Micro Advantage (.net) for his support.

Last edited by BB_Mike; 28 Nov 2004 at 04:01 AM
BB_Mike is offline   Reply With Quote
Old 23 Nov 2004, 02:43 PM   #2
Super Moderatress
 
cynthia's Avatar
 
Join Date: Jan 2004
Location: Sweden
Posts: 14,278
Default

Odd that your burning log showed it as DMA was enabled :

CdRomPeripheral : DVDRW IDE1008 atapi Port 1 ID 1 DMA: On
__________________
cynthia is offline   Reply With Quote
Old 23 Nov 2004, 04:00 PM   #3
Member
Member
 
Join Date: Aug 2004
Location: Huntsville, AL
Posts: 55
Default

Quote:
Originally posted by cynthia
Odd that your burning log showed it as DMA was enabled :

CdRomPeripheral : DVDRW IDE1008 atapi Port 1 ID 1 DMA: On
I belive there in is the microsoft bug. The device manager shows that DMA is selected as preferred for the particular drive, but in the field settin gjust below that drop-down option, is the text "PIO forced", or something like that. So, once a certain amount of CRC errors are seen, it negates what ever you prefer and begins to regress into more simpler means of communication.

All would be good an well, if Nero and DVD burning would work under PIO, however slow the actuall process is. Not the case though, but I think the fault is in now way Nero's. After all, it didn't show any kid of error log.

So long as you don't EVER use your DVD drive to read in a disk, you should never have this problem with regard to burning DVDs. during my bad media fiasco, I tried every angle possible. Including multiple isntances of reading bad CRC discs on my DVD-burner drive.

Might be best to include this bit of info with your usual DVD-info related posts about the common "bad media" complaints. just a forwarning to how a drive could be corrupted and leave one pulling their hair out, like me.

-sorry for the typos. I drank to celebrate.
BB_Mike is offline   Reply With Quote
Old 24 Nov 2004, 03:31 AM   #4
Junior Member
Junior Member
 
Join Date: Nov 2004
Posts: 27
Default

My LG burner is set to PIO, which probably explains all my woes. However, neither method to reset to DMA above works for me. Any ideas anybody?
Tim Who? is offline   Reply With Quote
Old 24 Nov 2004, 08:05 AM   #5
Member
Member
 
Join Date: Aug 2004
Location: Huntsville, AL
Posts: 55
Default

It's odd that neither attempt set yoru drive back to DMA.

At least you know the exact problem, and can email LG with your question.

Did you even try uninstalling the drvie all together? If so, do you have DMA selected as an option for the drive? Perhaps there is data-transfer issues between your drive and your CPU? like a cable, or such.
BB_Mike is offline   Reply With Quote
Old 24 Nov 2004, 01:52 PM   #6
Super Moderatress
 
cynthia's Avatar
 
Join Date: Jan 2004
Location: Sweden
Posts: 14,278
Default

http://support.microsoft.com/?kbid=817472
cynthia is offline   Reply With Quote
Old 24 Nov 2004, 09:57 PM   #7
Junior Member
Junior Member
 
Join Date: Nov 2004
Posts: 27
Default

I've tried uninstalling the secondary IDE channel and on reboot the following is shown :
Device 0 - Use DMA when available - set to Ultra DMA 2.
Device 1 - Use DMA when available - set to use PIO.

I have Windows XP SP2 installed.

I get the same thing when I try the registry fix.

Would the position of the jumpers on the drives make any difference? The master drive jumper is on CS (as set up in the factory) and the burner is set to slave. I've tried putting the burner on CS to see if that made any difference, but it didn't.
I can't get my master drive out to set the jumper to master (you need fingers like a child to get at the cables)
Tim Who? is offline   Reply With Quote
Old 25 Nov 2004, 02:36 AM   #8
Lord of Digital Video
Lord of Digital Video
 
Join Date: Sep 2003
Location: salisbury, UK
Posts: 2,399
Default

Would you believe that I'm a college tech supporting Computer Maintenance courses and I can't find a reference book that even mentions cable select? I've been wanting to get to the bottom of this for some time.
One thing I am sure of: if your machine was set up for CS you should comply with it with your added device. Otherwise you could for instance have a cable selected master and a master/slave master fighting each other.
Not very helpful toward your goal but at least a variable taken care of.

Umm, you haven't got another page in your BIOS with an option on enabling DMA on your primary slave?
__________________
This isn't a learning curve ... this is b****y mountaineering!

Last edited by sfheath; 25 Nov 2004 at 02:41 AM
sfheath is offline   Reply With Quote
Old 25 Nov 2004, 03:50 AM   #9
Junior Member
Junior Member
 
Join Date: Nov 2004
Posts: 27
Default

Quote:
Originally posted by sfheath
Would you believe that I'm a college tech supporting Computer Maintenance courses and I can't find a reference book that even mentions cable select? I've been wanting to get to the bottom of this for some time.
One thing I am sure of: if your machine was set up for CS you should comply with it with your added device. Otherwise you could for instance have a cable selected master and a master/slave master fighting each other.
Not very helpful toward your goal but at least a variable taken care of.

Umm, you haven't got another page in your BIOS with an option on enabling DMA on your primary slave?
Thanks for the reply. I haven't a clue about my BIOS and wouldn't really know what I was doing if I started playing with it, so I guess I'll have to wait to see if LG get back to me with a solution.
Tim Who? is offline   Reply With Quote
Old 25 Nov 2004, 08:39 AM   #10
Member
Member
 
Join Date: Aug 2004
Location: Huntsville, AL
Posts: 55
Default

Tim. During my trouble shooting, I did un-install service pack 2. While this shouldn't affect you from being able to delete the registry and reset the drive to DMA status, it's food for thought.

Perhaps your LG drive really has a damage DMA controller and PIO is the best you can hope for?! Let us know what LG says. They seem to be a popular burner.
BB_Mike is offline   Reply With Quote
Old 25 Nov 2004, 10:10 PM   #11
Junior Member
Junior Member
 
Join Date: Nov 2004
Posts: 27
Default

Thanks Mike. I will let you know when they get back to me.
Tim Who? is offline   Reply With Quote
Old 3 Dec 2004, 08:59 AM   #12
Junior Member
Junior Member
 
Join Date: Dec 2004
Posts: 13
Default

Tim-

Did u ever hear anything back from them???
I also have an LG burner 4120B and have follow the instructions detailed by Mike and Transfer Mode is still DMA if available but the grey area "Current Transfer Mode: says Pio Mode" remains the same even after editing the registry.
Anyone anymore thoughts on this???

Thanks in advance
lilc5 is offline   Reply With Quote
Old 3 Dec 2004, 10:36 PM   #13
Junior Member
Junior Member
 
Join Date: Nov 2004
Posts: 27
Default

They did reply, but all they said was that they would look into the issue and get back to me. It would be well worth you contacting them as well and posting any response you get from them. A friend has the 4120B and SP2, so I'll check his settings as well. Maybe it's an SP2 issue that will be addressed in the next firmware upgrade?
Tim Who? is offline   Reply With Quote
Old 4 Dec 2004, 07:16 AM   #14
Super Member
Super Member
 
charlypuss's Avatar
 
Join Date: Nov 2004
Location: Spain
Posts: 246
Default

Just for the record I did try BB_mike's registry fix and it worked firtst time. XP Pro SP1. The XP SP2 upgrade is still full of holes (I am only talking about the upgrade here). Most, but not all, of the insurmountable problems that I have come across with my customers equipment that have been upgraded have been resolved by uninstalling the SP2 upgrade... just a thought.
It is vitally important that all of the hard and soft ware is brought right uptodate BEFORE attempting to install XP SP2....
__________________
If it ain't afloat .... It's sunk .... If it ain't broke.... leave it alone.... I was once indecisive....Now I'm not sure....

I'm old enough to know better...BUT...too young to give a toss...
charlypuss is offline   Reply With Quote
Old 24 Dec 2004, 12:18 AM   #15
Junior Member
Junior Member
 
Join Date: Nov 2004
Posts: 27
Default

Ok... Still no response from LG, despite a couple more emails, so I have a question.

My DVD devices are set up on CS - this is the factory setting for the drive that came with the PC and I was advised to use CS for the burner.

I have looked into the BIOS settings and, I assume because I'm using CS for both devices on the secondary IDE channel, Secondary Slave is set to OFF. Would changing that to AUTO make any difference?

Sorry if that's a lame question, but I'm getting no help from LG. I'm able to burn workable discs 8 times out of 10, but they can take up to an hour and a half to burn.

Incidentally, my Dell PC came with SP2 already installed so removing the upgrade to try the fixes isn't an option. Is it?

To anyone thinking of buying an LG drive, all I can say is don't do it.

Last edited by Tim Who?; 24 Dec 2004 at 12:20 AM
Tim Who? is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT +10. The time now is 12:50 PM.

Kirsch designed by Andrew & Austin


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
Copyright © 1999 - 2011 Digital Digest

Visit DivXLand   Visit dvdloc8.com